Quantcast
lotrointerface.com
Search Downloads


Go Back   LoTROInterface > LotRO Tools & Utilities for Users

Category: LotRO Tools & Utilities for UsersLOTRO Plugin Compendium (Mac / Linux)
Interface Information
Download
How do I install this? (FAQ)
Name: LOTRO Plugin Compendium (Mac / Linux)   Popular!
Author:
Date: 11-26-2019 11:16 AM
Size: 16.61 MB
Version: 1.4-java11
Rate File: 5 out of 5 with 1 votes  
Pictures
Click to enlarge 

Views: 0
Size: 73.64 Kb
Dimensions: 988 x 732
Example of LPC (java version) running in Windows and Linux
 
Click to enlarge 

Views: 0
Size: 112.73 Kb
Dimensions: 850 x 525
LPC on Mac
 
Description
Intended for Mac / Linux (for now)
For Windows go here

NOTE: There are two versions of this due to significant changes introduced in Java. Make sure you download the correct version
For Java 11
1.4-java11

For Java 8
1.4


About

LOTRO Plugin Compendium (LPC) is a utility application to assist in installing and updating lotro LUA plugins. It attempts to take some of the leg work away from user having to manually download, create folders, and unzip download.

This is a platform independent version made available by request of the Mac and Linux crowd. Currently it has no installer, so while you could use it for windows, I would recommend you use the windows specific version http://www.lotrointerface.com/downloads/info663-LOTROPluginCompendium.html

Disclaimer
This application is an attempt to automate a manual process and help make things easier for LOTRO users. That said, if it does not work right, please report it below. I take no responsibility of it does not work on your PC or messes things up. I would, however, like to know about any problems you encounter so future versions can be fixed.

Known Issues
  • Please configure the Download Path on configuration panel for mac. It looks like mac might change the temp folder location. Since your settings are persisted and reloaded on startup, this is a bad thing if it goes away. I'd recommend setting to /tmp
  • Lack of Installer
  • in plugin description xml feed shows escaped characters.
  • Turbine Lotro Client seems to change the install location for Plugins. This can be configured by pointing the Install Path setting (on Configuration Tab) to something like
    ~/Library/Application Support/com.turbine.lotroclient/Plugins

Requirements
Java JRE/JDK 6+

Mac does not come with java by default. Please download http://www.oracle.com/technetwork/ja...s-2133155.html

Change Log


1.4
  • Fixed an issue with redirection of urls for api listing & downloads not being properly followed.
  • Fixed an encoding issue in detail pain for new addons
  • Updated compression library to latest as they discontinued older one used.

1.2
  • distribution for 1.2 was not properly updated.

1.2
  • fixed security issue preventing addins from being downloaded and installed
  • fix mac bug where many folders would get created if you manually typed in plugin path in configuration
  • added support for falling back to alternative rss data feed incase primary feeds go down again in future
  • fixed bug where prior version wasn't getting displayed correctly for plugins that were already installed.


1.1
  • fix mac bug where quitting application doesn't save settings
  • changed default download location for mac to /tmp
  • packaged java app as a mac application
  • made new higher rez icon for mac installer

1.0 Initial Release
Woohoo!
Archive List (Old Versions)
File Name
Version
Size
Author
Date
1.4
14.51 MB
lunarwtr
10-20-2018 05:02 PM
1.3
12.14 MB
lunarwtr
03-06-2016 12:17 PM
1.2
11.78 MB
lunarwtr
03-04-2016 10:51 PM
1.1
11.15 MB
lunarwtr
02-06-2012 10:59 PM
1.0
5.48 MB
lunarwtr
02-05-2012 05:52 PM
File Statistics
User Rating:
5 out of 5 with 1 votes
Downloads: 24252
Views: 130217
Favorites: 11
Uploaded By:
 
Last Modified: 11-26-2019 11:18 AM by lunarwtr    

View Pictures. Download Now! Post A Comment


Post A Reply
Author Comments Comment Options
Unread 08-07-2020, 08:26 AM  
lunarwtr
The Undying
 
lunarwtr's Avatar
Interface Author - Click to view interfaces

Forum posts: 85
File comments: 276
Uploads: 7
Re: Re: TitanBar won't Install

Also please check the configuration tab, what path and url you have listed there.
lunarwtr is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-07-2020, 08:06 AM  
lunarwtr
The Undying
 
lunarwtr's Avatar
Interface Author - Click to view interfaces

Forum posts: 85
File comments: 276
Uploads: 7
Re: TitanBar won't Install

HTML Code:
Hey there. I've managed to get a number of plugins installed, however TitanBar which works fine on my Windows partition, won't install on the Linux one. something about "unexpected element (uri:'', local: "Plugin") then lists the "expected elements".

Is this a LOTROinterface issue or a TitanBar one, do you know? Thanks.
Sounds like perhaps the plugin or plugincompendium file might have something in it that it does not like.
lunarwtr is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-07-2020, 06:42 AM  
lotrofamily
The Wary

Forum posts: 0
File comments: 4
Uploads: 0
Unhappy TitanBar won't Install

Hey there. I've managed to get a number of plugins installed, however TitanBar which works fine on my Windows partition, won't install on the Linux one. something about "unexpected element (uri:'', local: "Plugin") then lists the "expected elements".

Is this a LOTROinterface issue or a TitanBar one, do you know? Thanks.
lotrofamily is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 06-08-2020, 03:49 PM  
Browar
The Undefeated

Forum posts: 5
File comments: 3
Uploads: 0
i started the /plugincompendium.sh dont work.
i started plugincompendium-1.4-full.jar with OpenJDK and i worked, thank you for this tool!

Last edited by Browar : 06-08-2020 at 03:56 PM.
Browar is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 06-08-2020, 09:17 AM  
lunarwtr
The Undying
 
lunarwtr's Avatar
Interface Author - Click to view interfaces

Forum posts: 85
File comments: 276
Uploads: 7
Quote:
Hello ,

i am using Linux Mint 19.3 and i get this failure while running this wonderfull tool:

Problem while retrieving plugin listing

Implementation of JAXB-API has not been found on module path or classpath.

My java version:
openjdk 11.0.7

thank you
Did the one you downloaded say 1.4-java11 in the zip file name?
lunarwtr is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 06-06-2020, 11:02 AM  
Browar
The Undefeated

Forum posts: 5
File comments: 3
Uploads: 0
Hello ,

i am using Linux Mint 19.3 and i get this failure while running this wonderfull tool:

Problem while retrieving plugin listing

Implementation of JAXB-API has not been found on module path or classpath.

My java version:
openjdk 11.0.7

thank you
Browar is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 05-18-2020, 09:21 AM  
lunarwtr
The Undying
 
lunarwtr's Avatar
Interface Author - Click to view interfaces

Forum posts: 85
File comments: 276
Uploads: 7
Re: Error loading

Quote:
I did as the instructions said and downloaded java as well but still I get this error message:

Problem while retrieving plugin listing

null

How do I fix this any ideas?
This problem was not happening for me. Does the configuration tab look alright? Is the URL set to http://api.lotrointerface.com/fav/plugincompendium.xml

can you reach that url in a browser?
lunarwtr is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 05-11-2020, 07:54 AM  
loene
The Wary

Forum posts: 0
File comments: 1
Uploads: 0
Error loading

I did as the instructions said and downloaded java as well but still I get this error message:

Problem while retrieving plugin listing

null

How do I fix this any ideas?
loene is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 12-27-2019, 02:24 PM  
Emberleaf
The Unscathed
 
Emberleaf's Avatar

Forum posts: 17
File comments: 59
Uploads: 0
New version works perfectly on Linux Mint 19.3 - Thank you so much for all your hard work!!


I uploaded a new version for Java 11. I cannot test this on Mac, so if someone would be so kind as to do so.

If you are using Java 8, just download the older 1.4 version of the client.

(edit: looks like its awaiting approval. if it doesn't have java11 in the filename, it hasn't been approved yet)
Emberleaf is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 11-26-2019, 11:18 AM  
lunarwtr
The Undying
 
lunarwtr's Avatar
Interface Author - Click to view interfaces

Forum posts: 85
File comments: 276
Uploads: 7
I uploaded a new version for Java 11. I cannot test this on Mac, so if someone would be so kind as to do so.

If you are using Java 8, just download the older 1.4 version of the client.

(edit: looks like its awaiting approval. if it doesn't have java11 in the filename, it hasn't been approved yet)

Last edited by lunarwtr : 11-26-2019 at 11:44 AM.
lunarwtr is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 11-26-2019, 08:50 AM  
Drono
The Unscathed
Interface Author - Click to view interfaces

Forum posts: 19
File comments: 70
Uploads: 1
im java noob, but wouldnt this fix the issue?
stackoverflow javax-xml-bind-does-not-exist
Drono is online now Report comment to moderator   Reply With Quote Reply With Quote
Unread 11-26-2019, 08:07 AM  
Emberleaf
The Unscathed
 
Emberleaf's Avatar

Forum posts: 17
File comments: 59
Uploads: 0
Install openjdk8 for it to work for now.


Hmm...that did not seem to fix the issue. Still getting the same error message.
Emberleaf is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 11-18-2019, 10:25 PM  
lunarwtr
The Undying
 
lunarwtr's Avatar
Interface Author - Click to view interfaces

Forum posts: 85
File comments: 276
Uploads: 7
Install openjdk8 for it to work for now.
lunarwtr is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 11-18-2019, 01:58 PM  
Emberleaf
The Unscathed
 
Emberleaf's Avatar

Forum posts: 17
File comments: 59
Uploads: 0
"Problem while retrieving plugin listing"

Getting an error message that says:

"Implementation of JAXB-API has not been found on module path or classpath."

I'm using this on Linux Mint 19.3 if that helps. Thanks for any help/suggestions!
Emberleaf is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 06-11-2019, 06:43 AM  
binkley
The Wary

Forum posts: 0
File comments: 3
Uploads: 0
Advice for Java 11

Any advice/steps for Java 11? For example, JAXB has been removed from the stock JDK/JRE distributions.

Thanks!
binkley is offline Report comment to moderator   Reply With Quote Reply With Quote
Post A Reply

 
Category Jump:
Search this Category:
 

All times are GMT -5. The time now is 10:30 AM.


Our Network
EQInterface | EQ2Interface | Minion | WoWInterface | ESOUI | LoTROInterface | MMOUI | Swtorui