Quantcast
lotrointerface.com
Search Downloads


Go Back   LoTROInterface > LotRO Tools & Utilities for Users


Post A Reply
Author Comments Comment Options
Unread 01-22-2021, 05:22 PM  
homeopatix
The Wary
 
homeopatix's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 81
Uploads: 22
My biggest work so far

Hello lunarwtr,

can you add this Helper

AltHolic
there is the link
http://www.lotrointerface.com/downloads/info1126


Thank you very much, have a nice day and be well

Homeopatix
homeopatix is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-08-2021, 01:44 PM  
loikki
The Wary
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 8
Uploads: 1
Palantir III

Hey,

It seems that you have forgotten my plugin: https://www.lotrointerface.com/downl...1111#cmnt20754

Thanks!
loikki is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-08-2021, 01:33 PM  
homeopatix
The Wary
 
homeopatix's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 81
Uploads: 22
Hello, another small plugin

Hello lunarwtr,

can you add this little helper

Voyage
there is the link
http://www.lotrointerface.com/downloads/info1125


Thank you very much, have a nice day and Happy new year

Homeopatix
homeopatix is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-08-2021, 11:46 AM  
lunarwtr
The Undying
 
lunarwtr's Avatar
Interface Author - Click to view interfaces

Forum posts: 85
File comments: 284
Uploads: 7
Quote:
I was wondering if that can cause problems if I create plugin ID say 1234, somebody installs a plugin with dependency 0 and mine with dependency 1234, then Plugin Compendium will be installing the same code twice from different sources. ID 1234 would have a version number because of a .plugincompendium file. Will that be handled gracefully by LPC?
LPC will just overwrite the files if they are duplicated.
lunarwtr is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-08-2021, 07:23 AM  
Hyoss
The Undying
 
Hyoss's Avatar
Interface Author - Click to view interfaces

Forum posts: 104
File comments: 215
Uploads: 3
Quote:
You can already do this by taking uploading a new plugin.. Grab the ID of it.. and then start using that instead of 0
I was wondering if that can cause problems if I create plugin ID say 1234, somebody installs a plugin with dependency 0 and mine with dependency 1234, then Plugin Compendium will be installing the same code twice from different sources. ID 1234 would have a version number because of a .plugincompendium file. Will that be handled gracefully by LPC?

Last edited by Hyoss : 01-08-2021 at 07:23 AM.
Hyoss is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-07-2021, 05:39 PM  
lunarwtr
The Undying
 
lunarwtr's Avatar
Interface Author - Click to view interfaces

Forum posts: 85
File comments: 284
Uploads: 7
Quote:
What if we would add a new plugin to lotrointerface that would just have a zip of Turbine libraries without the examples? And Plugincompendium would understand dependency ID 1 as this plugin, rather than the full zip from Turbine/SSG.
You can already do this by taking uploading a new plugin.. Grab the ID of it.. and then start using that instead of 0
lunarwtr is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-07-2021, 05:23 PM  
Hyoss
The Undying
 
Hyoss's Avatar
Interface Author - Click to view interfaces

Forum posts: 104
File comments: 215
Uploads: 3
I'm not sure there is an easy way to accomplish this. 0 points at http://content.turbine.com/sites/lot..._LuaPlugins.7z which none of us have access to modify.

The easiest for now it to identify what you are using of turbines code, and include that in your lua code. If there really is a need to have some shared base UI code, this might be a good time to start a collaborative project and create a new dependency that can be maintained / updated.

Long term, I could always try to add more tagging support to the plugincompendium file to allow greater control of what gets installed from zip i.e. <exclude>folder/.*</exclude>

What if we would add a new plugin to lotrointerface that would just have a zip of Turbine libraries without the examples? And Plugincompendium would understand dependency ID 1 as this plugin, rather than the full zip from Turbine/SSG.
Hyoss is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-06-2021, 09:03 PM  
JLPicard
The Wary

Forum posts: 0
File comments: 4
Uploads: 0
It has been a long time since I updated the .net version of LPC. I will see if I can blow off the cobwebs soon.
Thanks for trying!
JLPicard is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-06-2021, 10:16 AM  
lunarwtr
The Undying
 
lunarwtr's Avatar
Interface Author - Click to view interfaces

Forum posts: 85
File comments: 284
Uploads: 7
Quote:
Windows 10 in may cases does not let you install Net 3.5, there's a large base of people that have tried over the years to get this to work, some have succeeded while others have not. It seems to be the version of W10 you have installed.

I have the latest Net Framework, but this requires 3.5.
It has been a long time since I updated the .net version of LPC. I will see if I can blow off the cobwebs soon.
lunarwtr is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-06-2021, 10:12 AM  
plugincompendium
The Wary
 
plugincompendium's Avatar

Forum posts: 0
File comments: 5
Uploads: 0
Quote:
@lunarwtr,

any idea how we could accomplish installation of turbine libraries only without the example plugins? I was wondering if a new upload to lotrointerface would work, but it would probably need special case handling like dependency ID 0. Because adding the Turbine libraries with a .plugincompendium file as ID X only as a dependency of some plugins, is a mess waiting to happen if some plugins have dependency 0 and some have X.
I'm not sure there is an easy way to accomplish this. 0 points at http://content.turbine.com/sites/lot..._LuaPlugins.7z which none of us have access to modify.

The easiest for now it to identify what you are using of turbines code, and include that in your lua code. If there really is a need to have some shared base UI code, this might be a good time to start a collaborative project and create a new dependency that can be maintained / updated.

Long term, I could always try to add more tagging support to the plugincompendium file to allow greater control of what gets installed from zip i.e. <exclude>folder/.*</exclude>
plugincompendium is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-06-2021, 05:07 AM  
Hyoss
The Undying
 
Hyoss's Avatar
Interface Author - Click to view interfaces

Forum posts: 104
File comments: 215
Uploads: 3
@lunarwtr,

any idea how we could accomplish installation of turbine libraries only without the example plugins? I was wondering if a new upload to lotrointerface would work, but it would probably need special case handling like dependency ID 0. Because adding the Turbine libraries with a .plugincompendium file as ID X only as a dependency of some plugins, is a mess waiting to happen if some plugins have dependency 0 and some have X.
Hyoss is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-05-2021, 12:02 PM  
homeopatix
The Wary
 
homeopatix's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 81
Uploads: 22
new addon to upload

Hello lunarwtr,

can you add this little helper

Profession
there is the link
http://www.lotrointerface.com/downloads/info1123


Thank you very much, have a nice day and Happy new year

Homeopatix
homeopatix is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-04-2021, 01:25 PM  
JLPicard
The Wary

Forum posts: 0
File comments: 4
Uploads: 0
Windows 10 in may cases does not let you install Net 3.5, there's a large base of people that have tried over the years to get this to work, some have succeeded while others have not. It seems to be the version of W10 you have installed.

I have the latest Net Framework, but this requires 3.5.

Last edited by JLPicard : 01-04-2021 at 01:26 PM.
JLPicard is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-03-2021, 11:22 AM  
homeopatix
The Wary
 
homeopatix's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 81
Uploads: 22
New addon to send to the compendium

Hello lunarwtr,

can you add this little helper

PopoHelper
there is the link
http://www.lotrointerface.com/downloads/info1122


Thank you very much, have a nice day and Happy new year

Homeopatix
homeopatix is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 01-02-2021, 02:35 PM  
lunarwtr
The Undying
 
lunarwtr's Avatar
Interface Author - Click to view interfaces

Forum posts: 85
File comments: 284
Uploads: 7
Quote:
Windows 10 and cannot load .net framework 3.5...
Just install a newer .net https://dotnet.microsoft.com/download/dotnet-framework
lunarwtr is offline Report comment to moderator   Reply With Quote Reply With Quote
Post A Reply

 
Category Jump:
Search this Category:
 

All times are GMT -5. The time now is 09:54 AM.


Our Network
EQInterface | EQ2Interface | Minion | WoWInterface | ESOUI | LoTROInterface | MMOUI | Swtorui