Quantcast Help with the Calculator Plugin - LoTROInterface
VGInterface.com
Search Downloads


Go Back   LoTROInterface > LotRO > General Discussion & Support > Interface Help (L)

Reply
Thread Tools Display Modes
  #1  
Unread 01-21-2011, 03:10 PM
Intrinsity's Avatar
Intrinsity Intrinsity is offline
The Wary
 
Join Date: Jan 2011
Posts: 2
Help with the Calculator Plugin

Hey all, brand new plugin user here and I am having a problem with the LOTRO Calculator plugin. I recently downloaded the plugin manager as well as lotropad and the travel plugin and all of those work perfectly. But the calculator gives me an error and I really want this one to work. Been dreaming of an in-game calculator since 2007...

Anyway, I get the following error on loading attempt:

...nline\Plugins\Willby\Calculator\CalculatorWindo w.lua:5: Unable to resolve package "Turbine.Utils".

... Rings Online\Plugins\Willby\Calculator\__init__.lua:1: Failed to import package "Willby.Calculator.CalculatorWindow".

... the Rings Online\Plugins\Willby\Calculator\Main.lua:3: Failed to import package "Willby.Calculator".


I re-downloaded and unzipped the Examples package that Narrel posted on the LOTRO forum to see if I had the wrong version of the Examples. But I still don't see a Turbine.Utils in that package...only a Turbine.MathUtils.

So I ask is there a way for me to get Turbine.Utils in the correct spot to make this calculator work? Or will I just have to wait for it to be updated by the creator? Anyone else have a similar problem with the Turbine.Utils package? Would it be possible for someone to copy and paste the old Turbine.Utils file here and I just save it to the Plugin folder?

Thanks in advance for any help.
Reply With Quote
  #2  
Unread 01-21-2011, 05:12 PM
Kragenwar Kragenwar is offline
The Undying
Interface Author - Click to view interfaces
 
Join Date: Sep 2010
Posts: 26
The files you need are there, just plugins that haven't been updated since the change look for them in the wrong spot. If you open the .lua files and replace any import Turbine.Utils at the top with just import Turbine it should resolve that issue.
Reply With Quote
  #3  
Unread 01-21-2011, 06:06 PM
Intrinsity's Avatar
Intrinsity Intrinsity is offline
The Wary
 
Join Date: Jan 2011
Posts: 2
Awesome, thanks! I'll give that a try.

EDIT: Yes this worked. Thanks again for the assist.

Last edited by Intrinsity : 01-21-2011 at 10:32 PM.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
plugin disappeared... scrappy Released Interfaces (L) 2 12-12-2010 02:23 PM
Need help fixing a plugin The Old One Lua Programming Help (L) 3 11-08-2010 09:27 PM
Better plugin management Olenn LotRO Wish List (L) 6 10-21-2010 12:09 AM
Plugin Manager 0.2 help jingo386 Script & Skin Managers 1 09-20-2010 11:33 PM
Plugin Manager Sirak Script & Skin Managers 8 09-12-2010 04:35 PM


All times are GMT -5. The time now is 03:36 AM.


Our Network
EQInterface | EQ2Interface | Minion | WoWInterface | VGInterface | LoTROInterface | MMOInterface | Swtorui