LoTROInterface (https://www.lotrointerface.com/forums/index.php)
-   Interface Help (L) (https://www.lotrointerface.com/forums/forumdisplay.php?f=3)
-   -   Plugins don't load images (https://www.lotrointerface.com/forums/showthread.php?t=3511)

Hildiroc 09-25-2014 06:28 AM

Plugins don't load images
Hi all! Thank you for your work, you have some amazing stuff in here!
I'm in need of your help because I tried installing some plugins and they seem to be fully functional except they cannot load their own resources (meaning backgrounds, buttons, icons etc.). They use games resources just fine though.
For instance, I'm using RecipeTracker and the result is this:

In the second image, right above the help button is what it supposed to be the icon I have to press to open up RecipeTracker.
This is not limited to RecipeTracker, I first noticed it on CombatAnalysis which used to work fine before I upgraded to Windows 8.1 (I used to have Windows 7 when I last saw it working I think, I'm not sure because I've switched back and forth a few times). And it's the same with TonicBars, so the issue must be global.

That would not be a very serious issue, because plugins are still functional, they just look ugly. But I tried installing Legendary UI of the Third Age because I thought it looks cool and frees up a lot of screen space (default UI sucks at this :() but with my problem it's completely unusable. When I first restarted the client, I got this:

and for some reason I had to alt-tab to make it a little better and got this:

Still unusable though.

Things I've tried so far with no luck:
  • Deleting the whole The Lord of the Rings Online folder from My Documents and reinstalling plugins using Compendium. (I had them installed manually at first)
  • Running LOTRO as administrator.
  • Running LOTRO in compatibility mode for Windows 7.

I hope there is a solution to this because I haven't found someone having similar issues by searching. Thank you for your time.

Garan 09-25-2014 10:24 AM

If the plugins load but do not show their own internal images, the problem is not with the plugins but rather with the game not being able to access the image files. It is a bit odd that it seems to be able to access the .lua files just fine but not the .jpg and .tga files.

One of two things has likely occurred. First is a possible permissions issue from the upgrade to Windows 8 however I see that you already removed the folder and redownloaded the plugins so this is no longer a likely candidate (although with inherited permissions it is still possible). The other issue might have to do with file associations - it shouldn't have anything to do with it, but I have seen other Windows 8 users report that having files associated with the default Windows image viewer can cause them to fail to load in other applications - you can try associating the .jpg and .tga files with a third party application such as Irfanview or Paint.Net and see if that helps. FWIW, I have .jpg files set to open with Irfanview for viewing and Windows paint for editing and .tga files associated with Paint.net for viewing and editing.

Hildiroc 09-26-2014 05:44 AM

Thanks for the reply Garan. I tried a lot of different security settings on the LOTRO folder in My Documents, I made sure I had ownership of the folder, I even gave full control to everyone at one point making sure that it would include all subfolders and files but nothing changed.
I also tried associating .tga files with a bunch of programs, I installed paint.net and associated it with them but still nothing changed. I'm really out of ideas.
Does LOTRO maybe keep a cache of temporary resources that I have to clear out or anything?

Garan 09-26-2014 07:00 AM


Originally Posted by Hildiroc (Post 11505)
Does LOTRO maybe keep a cache of temporary resources that I have to clear out or anything?

LotRO does cache images but it maintains the cache itself and clears it completely when the client closes. The only other issue I can think of would be lack of memory - or at least the client being denied memory by the OS. Unfortunately I am not familiar enough with Windows 8 memory management to give any advice on that. Have you posted this issue on the LotRO windows tech support forums? Also, your issue is not just with plugins as "Legendary UI of the Third Age" is a skin, not a plugin. So if you do post this there, make sure to point out that it is plugins AND skins. Have you tried disabling the skin to be sure you can get the built-in resources to reload correctly?

Hildiroc 09-26-2014 08:04 AM

Yes I have and built-in resources reload correctly.
You 're right, I'll try posting this in the LotRO forums, too.

Hildiroc 09-26-2014 08:19 AM

I was thinking maybe I'm missing some kind of library, that LotRO didn't find necessary to reinstall after I upgraded Windows. So here's a list of what I have installed (of what I think might be relevant):
  • Microsoft .NET Framework 4.5 Multi-Targeting Pack
  • Microsoft .NET Framework 4.5 SDK
  • Microsoft .NET Framework 4.5.1 Multi-Targeting Pack
  • Microsoft .NET Framework 4.5.1 Multi-Targeting Pack (ENU)
  • Microsoft .NET Framework 4.5.1 SDK
  • Microsoft Visual C++ 2005 Redistributable
  • Microsoft Visual C++ 2005 Redistributable (I have no idea why it's listed twice in my programs list)
  • Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.17
  • Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.6161
  • Microsoft Visual C++ 2010 x64 Redistributable - 10.0.40219
  • Microsoft Visual C++ 2010 x86 Redistributable - 10.0.40219
  • Microsoft Visual C++ 2012 Redistributable (x64) - 11.0.50727
  • Microsoft Visual C++ 2012 Redistributable (x64) - 11.0.60610
  • Microsoft Visual C++ 2012 Redistributable (x86) - 11.0.50727
  • Microsoft Visual C++ 2012 Redistributable (x86) - 11.0.60610

All times are GMT -5. The time now is 12:02 PM.

vBulletin® - Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.