Quantcast
VGInterface.com
Search Downloads


Go Back   LoTROInterface > LotRO Stand-Alone Plugins > Maps, coordinates & compasses


Post A Reply
Author Comments Comment Options
Unread 08-22-2018, 03:17 PM  
Thaliruth
The Wary
 
Thaliruth's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 50
Uploads: 1
With Update 23, it does not seem to work in the German client

Code:
Online\Plugins\Lunarwater\Waypoint\Waypoint.lua:318: attempt to perform arithmetic on local 'x' (a nil value)
Code:
Line 317 - 321
if xd == 'W' or xd == 'w' or (locale == 'de' and ( xd == 'o' or xd == 'O' )) then
			x = - x;
		end
		if yd == 'S' or yd == 's' then
			y = - y;
With English client it works as usual wonderful in Update23!
Thaliruth is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-22-2018, 04:48 PM  
Thurallor
The Undying
 
Thurallor's Avatar
Interface Author - Click to view interfaces

Forum posts: 167
File comments: 270
Uploads: 16
That's strange, I just tried it in the German client, and it worked for me.

Where is your character located when you get the error?
Thurallor is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-22-2018, 06:54 PM  
Thaliruth
The Wary
 
Thaliruth's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 50
Uploads: 1
Quote:
That's strange, I just tried it in the German client, and it worked for me.

Where is your character located when you get the error?
Currently on Bullroar Update 23 Build # 2
With Update 22 it was still working on Bullroarer.

nd it's everywhere, whether in Bree, Thalland or Grey Mountains.

Last edited by Thaliruth : 08-22-2018 at 06:56 PM.
Thaliruth is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-23-2018, 11:10 AM  
Thurallor
The Undying
 
Thurallor's Avatar
Interface Author - Click to view interfaces

Forum posts: 167
File comments: 270
Uploads: 16
Are you sure you're using the latest version (1.5)?

If so, can you tell me exactly what you do to generate the error? What's your "/way target" command?

There apparently are some undocumented changes on Bullroarer that break plugins, but I'm not seeing a problem with Waypoint on the German client.

Last edited by Thurallor : 08-23-2018 at 11:17 AM.
Thurallor is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-23-2018, 11:24 AM  
Thaliruth
The Wary
 
Thaliruth's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 50
Uploads: 1
I load the plugin normally, then I enter /way target 35.2N 39.8W and get the error as feedback. If I then enter this with the English client, this works strangely.

But let's see if it works after Official Release of u23 on Normal Server.
I contact you!

Last edited by Thaliruth : 08-23-2018 at 11:32 AM.
Thaliruth is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-23-2018, 12:25 PM  
Thaliruth
The Wary
 
Thaliruth's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 50
Uploads: 1
Bullroarer is offline, but I've tried it on the live server, because the plugin is unfortunately no longer synonymous. Get the same error. Reinstallation did not bring anything
Thaliruth is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-23-2018, 01:13 PM  
Thurallor
The Undying
 
Thurallor's Avatar
Interface Author - Click to view interfaces

Forum posts: 167
File comments: 270
Uploads: 16
I would try deleting the Settings file:
Documents\The Lord of the Rings Online\PluginData\account\AllServers\WaypointSettings.plugindata
Thurallor is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-23-2018, 01:20 PM  
lunarwtr
The Undying
 
lunarwtr's Avatar
Interface Author - Click to view interfaces

Forum posts: 85
File comments: 268
Uploads: 7
Quote:
I load the plugin normally, then I enter /way target 35.2N 39.8W and get the error as feedback. If I then enter this with the English client, this works strangely.

But let's see if it works after Official Release of u23 on Normal Server.
I contact you!
can you try

/way target 35.2N 39.8O

instead of

/way target 35.2N 39.8W

also..

What is the output when you do a /loc or ;loc in chat for your new updated client.

Are you logged into a character that is either in an instance or area that you've never used waypoint before? If so can you try going to a place that it has worked and try it.
lunarwtr is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-23-2018, 02:18 PM  
Thaliruth
The Wary
 
Thaliruth's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 50
Uploads: 1
When I enter /way target 35.2N 39.8O I get the same message

Code:
[08/23 09:11:40 PM] ...ings Online\Plugins\Lunarwater\Waypoint\Waypoint.lua:318: attempt to perform arithmetic on local 'x' (a nil value)
The command /loc does not exist in the German client. Here is only /pos or /position
Output: r1 lx1428 ly366 ox88.93 oy123.22 oz452.67 h222.2

I'm not in any instance, I'm in Grimbold's Camp
I deleted WaypointSettings.plugindata, but it does not work

Just in Mordor: Udun, it had last worked, just as in Thalland. But now it is no longer possible.

Even if I delete the folders PluginData and Plugin Complete. And reinstall Way Point Install Manuel or Plugin Compendium, it does not work anymore.

If I set the client from German to English it works wonderfully.

Last edited by Thaliruth : 08-23-2018 at 04:12 PM.
Thaliruth is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-23-2018, 07:09 PM  
lunarwtr
The Undying
 
lunarwtr's Avatar
Interface Author - Click to view interfaces

Forum posts: 85
File comments: 268
Uploads: 7
Quote:
When I enter /way target 35.2N 39.8O I get the same message

Code:
[08/23 09:11:40 PM] ...ings Online\Plugins\Lunarwater\Waypoint\Waypoint.lua:318: attempt to perform arithmetic on local 'x' (a nil value)
The command /loc does not exist in the German client. Here is only /pos or /position
Output: r1 lx1428 ly366 ox88.93 oy123.22 oz452.67 h222.2

I'm not in any instance, I'm in Grimbold's Camp
I deleted WaypointSettings.plugindata, but it does not work

Just in Mordor: Udun, it had last worked, just as in Thalland. But now it is no longer possible.

Even if I delete the folders PluginData and Plugin Complete. And reinstall Way Point Install Manuel or Plugin Compendium, it does not work anymore.

If I set the client from German to English it works wonderfully.
Thank you for confirming.

I've done some testing myself and was not able to reproduce this issue.

Are you using Windows, Mac, or Linux? I'm testing with Windows Standard version of game client.
lunarwtr is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-24-2018, 03:46 AM  
Thaliruth
The Wary
 
Thaliruth's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 50
Uploads: 1
That's mysterious when it works for you. As I said in the English client, it works with me too. But not in the German client, after Update22 it was still, then a few patches later not more.

I'll ask in the clan and in the world chat, if anyone has the problem.

Did you test with the German client?

Last edited by Thaliruth : 08-24-2018 at 03:54 AM.
Thaliruth is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-24-2018, 07:29 AM  
Thaliruth
The Wary
 
Thaliruth's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 50
Uploads: 1
I give up!
Other players seem to be okay too.
Have Lotro completely reinstalled. then I installed Way Point. Is the only plugin, type in / way target coordinates and it will not work.

If necessary, I play with the English client.
Thaliruth is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-24-2018, 10:59 AM  
Thurallor
The Undying
 
Thurallor's Avatar
Interface Author - Click to view interfaces

Forum posts: 167
File comments: 270
Uploads: 16
It is a mystery. Do you have a "Plugins/Turbine" folder? If so, try removing that. Depending on what's in it, that folder can change the behavior of all plugins.
Thurallor is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-24-2018, 01:13 PM  
Thaliruth
The Wary
 
Thaliruth's Avatar
Interface Author - Click to view interfaces

Forum posts: 0
File comments: 50
Uploads: 1
Quote:
It is a mystery. Do you have a "Plugins/Turbine" folder? If so, try removing that. Depending on what's in it, that folder can change the behavior of all plugins.
I deleted that folder, yes, but WayPoint still does not work on the German client. At least not with me.

Have already tried everything imaginable, unfortunately it always comes to the same mistake.
Thaliruth is offline Report comment to moderator   Reply With Quote Reply With Quote
Unread 08-24-2018, 01:49 PM  
Thurallor
The Undying
 
Thurallor's Avatar
Interface Author - Click to view interfaces

Forum posts: 167
File comments: 270
Uploads: 16
I am curious. If you are interested in helping to debug this, please add the code in green, at line 315:

Code:
    ...
    if y ~= nil and x ~= nil then
        if (tonum(x) == nil) then
            Turbine.Shell.WriteLine("locale = " .. tostring(locale));
            Turbine.Shell.WriteLine("Failed to convert: '" .. tostring(x) .. "'");
        end
        x = tonum(x);
        ...
Then post the resulting chat window output here.
Thurallor is offline Report comment to moderator   Reply With Quote Reply With Quote
Post A Reply

 
Category Jump:
Search this Category:
 

All times are GMT -5. The time now is 06:36 PM.


Our Network
EQInterface | EQ2Interface | Minion | WoWInterface | VGInterface | LoTROInterface | MMOInterface | Swtorui