Quantcast LoTROInterface - View Single Post - Problem Installing UI Theme
View Single Post
  #22  
Unread 07-16-2017, 04:25 PM
Silverangel's Avatar
Silverangel Silverangel is offline
The Indomitable
Interface Author - Click to view interfaces
 
Join Date: Nov 2010
Posts: 14
Quote:
Originally Posted by aimeusdietger
I encountered an almost similar problem with my themes but when i tried a different one it worked. When i tried installing the initial theme i wanted i had to use the FAQs guide on the site.
The missing image, showing as grey with a grid in the game, is a path problem to the image.

So if the UI is showing up as an option in game, then the game is finding the SkinDefinition.xml file. If you see grey blocks after selecting that ui theme, then some or all images are missing. Some of these interfaces are very outdated, and some of those grey blocks might be due to outdated re-definitions over time. The best you can do is open the SkinDefinition.xml file in a text editor and ensure that every definition line is going to an image with the correct relative folder path.

For example, for the below SkinDefinition.xml line, the image "accomplishment_book_background.tg" should be simply in the same main ui theme folder as the SkinDefinition file.

<Mapping ArtAssetID="accomplishment_book_background" FileName="accomplishment_book_background.tga"></Mapping>

In this definition, a sub-folder is added to the path, so the same image must be found in the "deedlog" folder inside the ui theme folder. If it isn't, you need to fix the path to the image, or delete the line from the SkinDefinition.xml file to make the grey blocks go away.

<Mapping ArtAssetID="accomplishment_book_background" FileName="deedlog/accomplishment_book_background.tga"></Mapping>

Last edited by Silverangel : 07-16-2017 at 04:38 PM.
Reply With Quote